V2 JSCAD Packages Available!



  • The V2 JSCAD project just took a huge step forward, as all V2 JSCAD packages have been published to NPM.

    Successfully published:
     - @jscad/cli@2.0.0-alpha.7
     - @jscad/core@2.0.0-alpha.7
     - @jscad/amf-deserializer@2.0.0-alpha.5
     - @jscad/amf-serializer@2.0.0-alpha.6
     - @jscad/dxf-deserializer@2.0.0-alpha.5
     - @jscad/dxf-serializer@2.0.0-alpha.5
     - @jscad/io-utils@2.0.0-alpha.5
     - @jscad/io@2.0.0-alpha.6
     - @jscad/json-deserializer@2.0.0-alpha.5
     - @jscad/json-serializer@2.0.0-alpha.5
     - @jscad/obj-deserializer@2.0.0-alpha.5
     - @jscad/stl-deserializer@2.0.0-alpha.5
     - @jscad/stl-serializer@2.0.0-alpha.5
     - @jscad/svg-deserializer@2.0.0-alpha.5
     - @jscad/svg-serializer@2.0.0-alpha.6
     - @jscad/x3d-serializer@2.0.0-alpha.6
     - @jscad/modeling@2.0.0-alpha.5
     - @jscad/array-utils@2.0.0-alpha.2
     - @jscad/img-utils@2.0.0-alpha.3
     - @jscad/regl-renderer@2.0.0-alpha.7
     - @jscad/vtree@2.0.0-alpha.6
     - @jscad/web@2.0.0-alpha.9
    lerna success published 22 packages
    

    For those looking to grab these from NPM, there's some special setup required. The above packages have been published with the 'alpha' tag to NPM. These are 'alpha' releases and therefore projects need to specifically use this tag.

    From the command line:

    npm install @jscad/modeling@alpha
    

    Inside NPM packages:

    "dependencies": {
      "@jscad/modeling": "alpha"
    }
    


  • @BarbourSmith Thanks.

    I noticed that as well. For now, you'll have to manually switch the version to 'alpha'.



  • These are FANTASTIC! I am already having great success using them.

    I've noticed something a little bit strange, but I'm not sure if its a bug. When I run

    npm install @jscad/modeling@alpha
    

    I get a successful install, but the dependency added to the package.json file looks like:

     "@jscad/modeling": "^2.0.0-alpha.5",
    

    Which ends up not working down the road when I run 'npm install' for the whole project.


Log in to reply